(unknown load command 5) - 1.2 Growl-WithInstaller.framework

The Growl forums have moved to Google Groups, this forum is read only.
kjbrock
Harmless
Posts: 3
Joined: Tue Oct 13, 2009 7:07 pm

(unknown load command 5) - 1.2 Growl-WithInstaller.framework

Postby kjbrock » Tue Oct 13, 2009 7:14 pm

I can't seem to build a project that uses Growl-WithInstaller.framework v1.2 with Xcode 3.1.4 on Leopard. Everything works fine if I'm building with Xcode 3.2 on SnowLeopard, but when I compile on Leopard I get the error:

strip: for architecture x86_64 object: <path to GWI.framework> malformed object (unknown load command 5)

Anyone have a clue about why this is happening? All of my code is building fine on 10.6 & 10.5 for both 32 & 64-bit architectures. Just the step that sets up the Growl framework fails.

We still need to be able to build on 10.5 for a time.

Kevin

rudy
Growl Team
Posts: 50
Joined: Tue Dec 07, 2004 12:33 am

Re: (unknown load command 5) - 1.2 Growl-WithInstaller.framework

Postby rudy » Tue Oct 13, 2009 9:23 pm

This specifically would mean that G-WI was built with x86_64 arch's Mac OS X Deployment OS set to 10.6, I'll file it as a bug when i get home.
C4 & Demolitions Expert / Ambrosia Software, Inc. / http://www.AmbrosiaSW.com/

kjbrock
Harmless
Posts: 3
Joined: Tue Oct 13, 2009 7:07 pm

Re: (unknown load command 5) - 1.2 Growl-WithInstaller.framework

Postby kjbrock » Tue Oct 13, 2009 11:00 pm

Interesting. It does successfully install and run on 10.5 if the package is built on 10.6.

I checked with otool and found that the unknown load command appears to be 0x00000022, which shows up as 'unknown' on 10.5 and as LC_DYLD_INFO on 10.6.

kjbrock
Harmless
Posts: 3
Joined: Tue Oct 13, 2009 7:07 pm

Re: (unknown load command 5) - 1.2 Growl-WithInstaller.framework

Postby kjbrock » Wed Oct 14, 2009 9:57 pm

I took a look at the Growl sources, and it didn't appear that any of the deployment targets were set higher than 10.5. Some were set *lower*, but I didn't see any higher.

bjhomer
Harmless
Posts: 6
Joined: Wed Jul 25, 2007 6:24 am

Re: (unknown load command 5) - 1.2 Growl-WithInstaller.framework

Postby bjhomer » Thu Oct 29, 2009 4:49 pm

Yes, it appears that there's a bug in Xcode 3.2 that causes frameworks to be built which the dev tools on 10.5 don't recognize.

A workaround for now is to download the Growl 1.2 source and rebuild it on Leopard. I did this yesterday and can verify that it works.

User avatar
boredzo
Cocoaforge Admin
Posts: 796
Joined: Mon Dec 06, 2004 7:49 am
Contact:

Re: (unknown load command 5) - 1.2 Growl-WithInstaller.framework

Postby boredzo » Fri Jan 22, 2010 7:56 am

This is fixed in Growl.framework 1.2.1. There is no WithInstaller version yet; that's waiting on Growl 1.2.1.

User avatar
boredzo
Cocoaforge Admin
Posts: 796
Joined: Mon Dec 06, 2004 7:49 am
Contact:

Re: (unknown load command 5) - 1.2 Growl-WithInstaller.framework

Postby boredzo » Sat Aug 14, 2010 4:25 am

Growl 1.2.1 is now out, with Growl-WithInstaller.framework 1.2.1 included in its SDK. Please let us know through the growldiscuss Google Group (since this forum is closed) whether that works for you.


Return to “Growl”

Who is online

Users browsing this forum: Google [Bot], Majestic-12 [Bot]