Stuck in passthrough mode?

The Perian forums have moved to Google Groups, this forum is read only.
ephemeris
Harmless
Posts: 1
Joined: Mon Jul 04, 2011 3:36 pm

Stuck in passthrough mode?

Postby ephemeris » Mon Jul 04, 2011 3:51 pm

I've used Perian successfully for a long time but something has broken for me which may or may not be related to Perian. In any case I'd appreciate suggestions.

I've been using a first generation Mac Pro as a media PC for the last year or so running XBMC for video and iTunes for music. The Mac Pro is hooked to a Denon receiver. Until a week ago I had no problem watching AC3 5.1 encoded videos and movies with AAC stereo soundtracks. Both still work initially, but once I play an AC3 5.1 encoded video I cannot go back to stereo! I've toggled every setting I can think of and nothing but a reboot lets me go back to normal stereo playback. If I try to play a song in iTunes I get silence.

Here's a possible clue, if I play an AC3 encoded movie after the problem starts, and try to play a song in iTunes at the same time, the song comes out of the Mac's built-in speaker. But if I shut down the movie and try to play the song I get silence!

I am running the current version of Perian and recently updated to OS X 10.6.8

So that's my problem. I doubt this is a Perian issue per se so please let me apologize in advance for being off topic. Nonetheless, folks here seem to be my best hope for a solution. Thanks!

gbooker
Cocoaforge Admin
Posts: 723
Joined: Sat May 06, 2006 2:47 am
Contact:

Re: Stuck in passthrough mode?

Postby gbooker » Mon Jul 04, 2011 5:53 pm

From your description, Perian isn't being used in any of these circumstances.

ephemeris wrote:running XBMC for video

I'd suggest that this is the culprit. You'd likely have better luck on their forums.


Return to “Perian”

Who is online

Users browsing this forum: Bing [Bot]