Cannot Build

The Perian forums have moved to Google Groups, this forum is read only.
User avatar
mysticalos
Harmless
Posts: 8
Joined: Tue May 31, 2005 4:43 am
Location: Georgia
Contact:

Cannot Build

Postby mysticalos » Fri Mar 18, 2011 7:23 am

No matter what I do, missing files. I've done clean svn downloads with corner stone and terminal, tried building in xcode 3.2.6, 4.0, sdk 10.5 10.6 sdk with all the proper changes. running makefile script with "make Perian" but no matter what result is always same, missing files

ffmpeg/libavutil/common.h:38:32: error: libavutil/avconfig.h: No such file or directory

i've tried working around this by adding file and it then can get passed this but gets hung up on a few more missing files

looking at svn checkout externals, it's got properties to ignore these files yet they are required by project?

I've built perian for years i've never had problems until very recently. where can i easily get all the missing files? 99% of the videos i use perian for are videos that crash it (issue 555). I've gone through all the documentation but there are really no helpful resources on webpage, mailing list, readme files, or even 6 hours worth of googling that i could find. everything says it should just build fine with the make file script or in xcode.

gbooker
Cocoaforge Admin
Posts: 723
Joined: Sat May 06, 2006 2:47 am
Contact:

Re: Cannot Build

Postby gbooker » Fri Mar 18, 2011 12:02 pm

mysticalos wrote:ffmpeg/libavutil/common.h:38:32: error: libavutil/avconfig.h: No such file or directory

There's a reason this file doesn't exist and it's clear that there is an error preceding this one. Look at the first error message and see what it says.

User avatar
mysticalos
Harmless
Posts: 8
Joined: Tue May 31, 2005 4:43 am
Location: Georgia
Contact:

Re: Cannot Build

Postby mysticalos » Fri Mar 18, 2011 5:11 pm

that is the first error message

http://pastebin.com/bUWD8Mae

gbooker
Cocoaforge Admin
Posts: 723
Joined: Sat May 06, 2006 2:47 am
Contact:

Re: Cannot Build

Postby gbooker » Fri Mar 18, 2011 9:24 pm

That's still not the first error message. The first message is with building ffmpeg. You need to delete the build directory first.

User avatar
mysticalos
Harmless
Posts: 8
Joined: Tue May 31, 2005 4:43 am
Location: Georgia
Contact:

Re: Cannot Build

Postby mysticalos » Fri Mar 18, 2011 9:31 pm

http://pastebin.com/FSFqMU5d

i have delete build folder and cleaned all targets before every attempt

gbooker
Cocoaforge Admin
Posts: 723
Joined: Sat May 06, 2006 2:47 am
Contact:

Re: Cannot Build

Postby gbooker » Sat Mar 19, 2011 1:57 am

Chalk this up to Apple fscking up xcode:
It built ffmpeg with
setenv ARCHS "x86_64 i386"


The project has not been modified, yet it does this with the newer xcodes. Furthermore, attempting to change the architecture settings no longer yields an item that enables any ppc (which is what's failing to build). Apparently $(ARCHS_STANDARD_32_64_BIT) means only intel processors now.

User avatar
zac
Cocoaforge Admin
Posts: 1518
Joined: Sun Mar 27, 2005 3:19 pm
Contact:

Re: Cannot Build

Postby zac » Sat Mar 19, 2011 3:04 am

Xcode 4 dropped PPC build support entirely.

User avatar
mysticalos
Harmless
Posts: 8
Joined: Tue May 31, 2005 4:43 am
Location: Georgia
Contact:

Re: Cannot Build

Postby mysticalos » Sat Mar 19, 2011 4:35 am

this build is in xcode 3.2.6 which was released at same time as 4.x GM :\ and 10.5 sdk and 10.4 sdk were both installed as well. since i know xcode 4 doesn't have em.

User avatar
mysticalos
Harmless
Posts: 8
Joined: Tue May 31, 2005 4:43 am
Location: Georgia
Contact:

Re: Cannot Build

Postby mysticalos » Sat Mar 19, 2011 5:40 am

woot i got it to build, i just checked "build active architecture only" in the perian info which i guess convinced it not to screw around with PPC, heh.

although hmm strange, it generated a 32 bit version, even the pref pane has to launch in 32 bit mode. intresting thing is current arch is 64 bit, i'm even using a 64 bit kernel boot. I'll have to mess with it more

bah it looks like ticket 555 only fixed the crash, not the actual playback issues, oh well, was worth a try anyways :) Guess I may actually be stuck with a divx or xvid codec external to perian. god i hate both of em :\ Why do people even code stuff in such terrible formats still :(

gbooker
Cocoaforge Admin
Posts: 723
Joined: Sat May 06, 2006 2:47 am
Contact:

Re: Cannot Build

Postby gbooker » Sat Mar 19, 2011 1:08 pm

mysticalos wrote:t generated a 32 bit version, even the pref pane has to launch in 32 bit mode. intresting thing is current arch is 64 bit, i'm even using a 64 bit kernel boot. I'll have to mess with it more

QuickTime components are only 32-bit ATM. The pref-pane does build in 64-bit, but xcode has likely screwed that up too. The same is likely true of the audio components in Perian as well.

mysticalos wrote: Guess I may actually be stuck with a divx or xvid codec external to perian.

Then you'll have to deal with all the bugs they introduce. You'll be better off without them. During playback in the web browser, Perian is told to draw frames, but the drawn frames never make it to the browser itself, so it's not a Perian issue.

User avatar
mysticalos
Harmless
Posts: 8
Joined: Tue May 31, 2005 4:43 am
Location: Georgia
Contact:

Re: Cannot Build

Postby mysticalos » Sat Mar 19, 2011 4:55 pm

yeah it seems those videos are waiting for divx plugin to ask for the frames or something, they aren't even sent, only the audio track is. and i know how bad divx is, utter garbage.

Mr VacBob
Crema
Posts: 330
Joined: Thu Jan 04, 2007 11:14 pm
Contact:

Re: Cannot Build

Postby Mr VacBob » Wed Apr 13, 2011 5:33 am

The project will be updated for Xcode 4 compatibility soonish. I would expect the current one to work with 3.2.6, though.

User avatar
mysticalos
Harmless
Posts: 8
Joined: Tue May 31, 2005 4:43 am
Location: Georgia
Contact:

Re: Cannot Build

Postby mysticalos » Wed Apr 13, 2011 5:47 am

it builds with 3.2.6 but only if you force it to build intel only and ignore ppc instructions. ppc is no longer included in 3.2.6

Mr VacBob
Crema
Posts: 330
Joined: Thu Jan 04, 2007 11:14 pm
Contact:

Re: Cannot Build

Postby Mr VacBob » Fri Apr 15, 2011 7:01 am

Huh, I forgot the compiler spec was broken in 3.2.6. Semi-fixed on trunk - the resulting build will work on G4 but not G3.


Return to “Perian”

Who is online

Users browsing this forum: No registered users