No QT in FF an Safari anymore

The Perian forums have moved to Google Groups, this forum is read only.
karlmartell
Harmless
Posts: 3
Joined: Tue Jul 03, 2007 7:37 pm

No QT in FF an Safari anymore

Postby karlmartell » Tue Jul 03, 2007 7:50 pm

I installed Perian (intel iMac 20'', OS X) and the results are pretty frustrating.

First QT started to flicker when playing clips from the apple page. Having restarted the system it's a no go now: QT neither works in FF nor Safri; Safari even complains QT wasn't installed at all.

Deinstalling Perian didn't help, nor did reinstalling QT.

Now what? So far Perian was less a Swiss Army knife but more a hand ax that wreaked havoc on my browsers.

Any ideas anybody?

karl martell

User avatar
The_Tick
Cocoaforge Admin
Posts: 4642
Joined: Thu Dec 02, 2004 6:06 am
Contact:

Postby The_Tick » Tue Jul 03, 2007 8:23 pm

Perian can't do things like that. Were you having problems before?

karlmartell
Harmless
Posts: 3
Joined: Tue Jul 03, 2007 7:37 pm

Well

Postby karlmartell » Tue Jul 03, 2007 8:33 pm

This would be a coincidence indeed - I've had this computer for over a year now and I've never had any problems whatsoever with playing QT media in FF or Safari.

I only installed Perian yesterday and now QT doesn't work anymore.

Coincidence? Maybe I should go and buy a lottery ticket.

karl martell

User avatar
The_Tick
Cocoaforge Admin
Posts: 4642
Joined: Thu Dec 02, 2004 6:06 am
Contact:

Postby The_Tick » Tue Jul 03, 2007 8:48 pm

If perian is removed it can't do anything, it's a plugin and plugin code CANNOT load unless it is present.

How did you remove Perian?

User avatar
The_Tick
Cocoaforge Admin
Posts: 4642
Joined: Thu Dec 02, 2004 6:06 am
Contact:

Postby The_Tick » Tue Jul 03, 2007 8:58 pm

Run this while Firefox is having the problem, in a terminal. Let's see if Perian is even loaded:

vmmap -w Firefox

User avatar
Robby
Cocoaforge Admin
Posts: 2570
Joined: Mon May 01, 2006 3:00 am
Contact:

Postby Robby » Tue Jul 03, 2007 9:34 pm

You've won in the lottery, Karl Martell:
The_Tick reacted exceptionally friendly considering that you were so rude.
Perian is freeware, the developers don't owe you anything!

karlmartell
Harmless
Posts: 3
Joined: Tue Jul 03, 2007 7:37 pm

rude?

Postby karlmartell » Tue Jul 03, 2007 10:00 pm

Well, I fail to see where I've been rude. I expressed my frustration that an - admittedly free - piece of software has unexpected and undesirable effects on my system.

Still, there is always the remote possibility my probs with Perian and Quicktime are just the result of a freak coincidence.

karl martell

PS I removed it with a click on the entry where it says 'remove'.

User avatar
The_Tick
Cocoaforge Admin
Posts: 4642
Joined: Thu Dec 02, 2004 6:06 am
Contact:

Postby The_Tick » Tue Jul 03, 2007 11:04 pm

Let's get back to fixing it, if we can.

Karl, can you run that command?

Oddjob
Harmless
Posts: 1
Joined: Sat Jul 07, 2007 8:20 pm
Location: Bristol, UK

Postby Oddjob » Sat Jul 07, 2007 8:36 pm

Shame this thread died, im also getting the Flickering issue when i watch the embedded quicktime videos on Apple's website with Perian 1.0 installed and using Firefox (2.0.0.4)

It started when i installed Perian 1.0
The problem goes away if i remove Perian 1.0 (uninstalling using the Pref Pane)

The flickering does not occur on Safari or Camino with Perian 1.0 installed.

I ran the vmmap -w Firefox command at a prompt when experiencing the problem in firefox, searching for Perian in the results i get the following lines in the output...

__TEXT 190e9000-192cc000 [ 1932K] r-x/rwx SM=COW /Users/Mal/Library/QuickTime/Perian.component/Contents/MacOS/Perian [/Users/Mal/Library/QuickTime/Perian.component/Contents/MacOS/Perian]
__LINKEDIT 1932c000-193f6000 [ 808K] r--/rwx SM=COW /Users/Mal/Library/QuickTime/Perian.component/Contents/MacOS/Perian [/Users/Mal/Library/QuickTime/Perian.component/Contents/MacOS/Perian]


__DATA 192cc000-192ee000 [ 136K] rw-/rwx SM=COW /Users/Mal/Library/QuickTime/Perian.component/Contents/MacOS/Perian [/Users/Mal/Library/QuickTime/Perian.component/Contents/MacOS/Perian]
__DATA 192ee000-19329000 [ 236K] rw-/rwx SM=PRV /Users/Mal/Library/QuickTime/Perian.component/Contents/MacOS/Perian [/Users/Mal/Library/QuickTime/Perian.component/Contents/MacOS/Perian]
__IMPORT 19329000-1932b000 [ 8K] rwx/rwx SM=COW /Users/Mal/Library/QuickTime/Perian.component/Contents/MacOS/Perian
__OBJC 1932b000-1932c000 [ 4K] rw-/rwx SM=COW /Users/Mal/Library/QuickTime/Perian.component/Contents/MacOS/Perian

i assume this means its being loaded and used?

if you need anymore info then please ask, thanks for any help you can offer.

MacBook Pro Core2 2.33, Mac OS X 10.4.10

stalefries
Harmless
Posts: 3
Joined: Mon Jul 09, 2007 3:02 am

Postby stalefries » Mon Jul 09, 2007 3:07 am

I can confirm that I am also having this problem. Firefox sometimes crashes whenever Quicktime is loaded, and it has the flickering issues, also.

I have had other issues that may or may not be related (they started at the same time), I've been documenting them at the Apple forums, this thread.


Return to “Perian”

Who is online

Users browsing this forum: No registered users