Poll: What version of Mac OS X do you use?

An RSS/Atom newsreader with features comparable to commercial newsreaders.

What is the main version of Mac OS X you use?

Mac OS X 10.8
1
3%
Mac OS X 10.9
3
10%
Mac OS X 10.10
2
7%
Mac OS X 10.11
10
33%
macOS 10.12
14
47%
 
Total votes: 30

User avatar
josh64x2
Cocoaforge Admin
Posts: 153
Joined: Sat Sep 06, 2014 1:38 am
Location: Sydney, Australia
Contact:

Poll: What version of Mac OS X do you use?

Postby josh64x2 » Thu Dec 15, 2016 1:56 am

Here is a poll to see what version of Mac OS X is used the most by Vienna users.
There will be some new polls in the coming days/weeks so we can decide what direction in which to take Vienna.

If you are using 10.8 or 10.9 please reply and tell us why you like those older versions :)

Thanks!
Josh
I help with Vienna development.

beekay
Harmless
Posts: 16
Joined: Sat Mar 23, 2013 3:16 pm

Re: Poll: What version of Mac OS X do you use?

Postby beekay » Thu Dec 15, 2016 4:33 am

I am on 10.8.5 to avoid the contrastless UI of 10.9+ that gives me eyestrain and the ridiculous bouncing-content effect that gives me motion sickness. It would be a real shame if Vienna were to stop supporting 10.8.

dkbarto
Harmless
Posts: 12
Joined: Fri Mar 15, 2013 7:55 pm

Re: Poll: What version of Mac OS X do you use?

Postby dkbarto » Thu Dec 15, 2016 2:44 pm

I use either 10.10.5 or 10.11.6, depending if I'm at work or not.

kwinieck
Harmless
Posts: 19
Joined: Mon Jan 12, 2015 11:19 pm

Re: Poll: What version of Mac OS X do you use?

Postby kwinieck » Thu Dec 15, 2016 3:05 pm

10.12

smoliar
Harmless
Posts: 3
Joined: Tue Jul 09, 2013 5:37 pm

Re: Poll: What version of Mac OS X do you use?

Postby smoliar » Thu Dec 15, 2016 5:20 pm

10.12.2

cursa
Harmless
Posts: 1
Joined: Thu Dec 15, 2016 5:31 pm

Re: Poll: What version of Mac OS X do you use?

Postby cursa » Thu Dec 15, 2016 5:35 pm

10.10.5

I can't upgrade as this is a work machine and IT have told me that later versions won't work with some of their network services. Apparently they aren't planning any updates.

budjoe
Harmless
Posts: 4
Joined: Mon Nov 11, 2013 12:29 pm

Re: Poll: What version of Mac OS X do you use?

Postby budjoe » Thu Dec 15, 2016 7:36 pm

Still at 10.9.5

Largely due to web site development and have apache and mysql set and configured for the development work.
Expect to update, but haven't set aside the time to update and rebuild and configure the needed apache and mysql.

dcpc
Harmless
Posts: 5
Joined: Thu Oct 25, 2007 6:47 pm

Re: Poll: What version of Mac OS X do you use?

Postby dcpc » Thu Dec 15, 2016 8:16 pm

10.10.5

User avatar
David Munch
Grandé
Posts: 878
Joined: Sun Dec 05, 2004 3:41 pm
Location: Denmark
Contact:

Re: Poll: What version of Mac OS X do you use?

Postby David Munch » Thu Dec 15, 2016 10:40 pm

10.11 and 10.12 depending on the machine.
For Vienna issues: Please search Github before posting! Otherwise, file a bug report on Github.

If you are interested in helping out with the development of Vienna, see the Vienna website for details. All levels of programming experience are welcome! :grin:

HarryCovert
Harmless
Posts: 15
Joined: Wed Sep 19, 2012 9:50 am
Location: France

Re: Poll: What version of Mac OS X do you use?

Postby HarryCovert » Fri Dec 16, 2016 12:14 pm

10.12 on this Macbook Pro, 10.11 on the iMac (too old to get 10.12)

mbesh
Harmless
Posts: 1
Joined: Fri Dec 16, 2016 2:56 pm

Re: Poll: What version of Mac OS X do you use?

Postby mbesh » Fri Dec 16, 2016 2:58 pm

We use 10.9.5 (Mavericks), since is is the latest version that will run the old Final Cut Pro 7 and CS5.

cornel
Harmless
Posts: 3
Joined: Sun Aug 21, 2016 10:09 am

Re: Poll: What version of Mac OS X do you use?

Postby cornel » Fri Dec 16, 2016 3:45 pm

10.10.5 that is.

Chimera
Harmless
Posts: 1
Joined: Fri Dec 16, 2016 10:10 pm

Re: Poll: What version of Mac OS X do you use?

Postby Chimera » Fri Dec 16, 2016 10:26 pm

Trailing-edge user who switches Macs as needed (redundancy).

Until this past September when the hard drive died, i was using Safari 4.1.3’s built-in RSS reader or the kinda-sorta-not really functionality of TenFour Fox, under OS 10.4.11 Tiger. Yes—as a daily-use full-service OS on a PowerBook5,6.

I’ve been hanging back with Vienna 3.0.9, so that i can use ChronoSync to sync its settings files and so on when i move between a Late 2006 white iMac which doesn’t go past OS 10.7.5 Lion, and the Mid 2012 Non-Retina MacBook Pro 15" running OS 10.11.6 El Capitan i’m using at the moment.

My vote is for the developers to support the oldest macOS/OS X possible without killing themselves or denying users of current OSes truly useful features/stability/security. There is a chance that if Apple continues to fail to fix its bugs in Mail, i may need to revert to OS 10.9, as that was the last one where S/MIME actually fully functioned correctly in Mail (i count on functional S/MIME email in Mail), so it would be nice if Vienna could continue to at least support that far back if further is not reasonable.

****
Note to admin: this cocoaforge board has a serious problem with failing to send registration emails. It’s taken me several days and 4 account creation attempts to be able to post. I mention this here because your poll may be skewed, on account of people who want to vote, but can’t sign in. (And there’s no way to contact an admin unless one can sign in! Other than maybe the Whois contact address.) You may wish to consider keeping this poll open longer, to allow the issue to be resolved and more Vienna users to sign on and vote/comment.

User avatar
josh64x2
Cocoaforge Admin
Posts: 153
Joined: Sat Sep 06, 2014 1:38 am
Location: Sydney, Australia
Contact:

Re: Poll: What version of Mac OS X do you use?

Postby josh64x2 » Fri Dec 16, 2016 11:21 pm

Some good responses so far!

So far I'm definitely going to stop supporting 10.8 unfortunately, but 10.9 is safe for now. We will still fix any major bugs for a while but no major work will be done. That being said, anyone can come along and fork Vienna and work on the older versions if they wish.
Unfortunately there are only two "regular" developers working on Vienna and the site administration and we only have so much time between us.

Vienna currently has A LOT (> 50%) of legacy code which is the main source of bugs. Over the last 10 years Apple have made many changes to the developer APIs for Mac OS X which automatically provide features that we currently have buggy code doing from when they didn't provide those features.

@beekay - Can I suggest you look at moving to 10.9 as it retains the same UI Styling as 10.8? 10.10 is where it changed to the "flat" design.

@chimera - looking into the mailing issues now, thanks for reporting it! I will keep the poll open longer.

(If it were easy enough I'd still be supporting 10.4 on PowerPC)
I help with Vienna development.

tvs
Harmless
Posts: 1
Joined: Fri Dec 16, 2016 3:13 am

Re: Poll: What version of Mac OS X do you use?

Postby tvs » Sat Dec 17, 2016 2:35 am

10.12

tut
Harmless
Posts: 2
Joined: Tue Jun 21, 2016 3:35 am

Re: Poll: What version of Mac OS X do you use?

Postby tut » Sat Dec 17, 2016 5:54 am

10.12.1

I usually the latest, although I let the suckers find the bugs in major releases for a few months before upgrading.

What's really surprising is how many people are using old OSes. Lordy, that's sad.

eddekker
Harmless
Posts: 5
Joined: Tue Sep 03, 2013 11:53 am

Re: Poll: What version of Mac OS X do you use?

Postby eddekker » Sat Dec 17, 2016 12:31 pm

tut wrote:10.12.1

I usually the latest, although I let the suckers find the bugs in major releases for a few months before upgrading.

What's really surprising is how many people are using old OSes. Lordy, that's sad.


Macs live longer than the OSes supporting them. My good old iMac 24" cannot run Sierra (10.12) unless I hack it.

TheHammer610
Harmless
Posts: 3
Joined: Mon Jul 21, 2014 2:51 pm

Re: Poll: What version of Mac OS X do you use?

Postby TheHammer610 » Sat Dec 17, 2016 4:18 pm

I stayed on Mac OS 10.6.8 (Snow Panther) until a week ago because I have a few software programs that I need that run only on PowerPC architecture and 10.6 was the last Mac OS to run it.

I am just now on Sierra 10.12 and have a iMac (21.5-inch, Late 2009) that is running it.

The toughest adjustment for me, besides losing those programs, is getting Photos to do what iPhoto did easily. I dislike it intensely. Plus they keep making iTunes dumber.

If Apple ever makes an iMac that uses the newer Intel processors, I will consider upgrading. But I dislike that I can no longer even upgrade the RAM, much less anything else. I so miss the old Mac hardware where I could open it up and replace my drive and RAM.

Sonic Purity
Harmless
Posts: 1
Joined: Sat Dec 17, 2016 2:35 am

Re: Poll: What version of Mac OS X do you use?

Postby Sonic Purity » Sat Dec 17, 2016 7:39 pm

tut wrote:I usually the latest, although I let the suckers find the bugs in major releases for a few months before upgrading.

What's really surprising is how many people are using old OSes. Lordy, that's sad.


(Same person as Chimera here. This is my actual account going forward. Big Thanks to Josh for the quick fix!)

I find that it takes Apple nearly until the release of the newest OS for enough “suckers” to have worked with them and them to have gotten their act together enough that there might be a faint hope that the about-to-be-not-current OS is stable enough for me to actually use without wasting my time on Apple’s bugs.

Why is using an older OS “sad”? New ≠ Best, in many instances.

Why do i use older OSes? One word: Stability.

Today i’ve lost about 3 hours of my life so far to a brand-new crashing bug, generated by the 10.11.6 Security Update + Safari 10.0.2 update of a couple of days ago. Can’t concentrate on my novel, with crash windows spontaneously popping up at random times, unrelated to what i’m doing. My PowerBook/Tiger system does not have those issues: it’s dialed in and stable. Yes it is primitive. Yes it has some security issues (which i work around). No it is not viable for a smooth, fast, 100% 2016 WWW experience, but i can get it to do the 80% i need. I’m almost at the point of getting with OWC for a replacement hard (well, SSD) drive for that system and going back to it, so i can get productive work done. (I’ve also got a 9600/350 running a highly tuned OS 9.1 which is super-stable, which i still use occasionally for expensive software like Photoshop and FileMaker Pro i don’t want to pay to upgrade just to do the same things on a newer Mac.)

In the case of Vienna, i’ve been sitting back and smiling, using 3.0.9 without problems, reading here about the various issues with the newer versions. At least unlike Apple Josh and others here deal with bugs in a timely manner and fix things—yaaaaay! I have serious failure bugs in to Apple which they’ve had in their Radar bug tracker for years and many OS versions and still have yet to fix—not a one! (BTW, i used to work at Apple: software QA. They used to pay me to report bugs, and now when i’m doing it for free, they ignore them.)

For those of you who stay current and have no issues, i applaud you! That has seldom been my reality. Hence my posting in this thread, hence my appreciation that Vienna will continue to support older OSes as it reasonably can without harming current-OS users nor overburdening the developers.

))Sonic((

tut
Harmless
Posts: 2
Joined: Tue Jun 21, 2016 3:35 am

Re: Poll: What version of Mac OS X do you use?

Postby tut » Sun Dec 18, 2016 5:28 am

Why is using an older OS “sad”? New ≠ Best, in many instances.

It's incredibly sad to developers. It's usually a major pain the butt to support old versions of the OS when you need to add new features to your software. I've managed to be a developer in the print and music industry since 1995, two areas where the users hate change and often work for companies that can't afford to buy new equipment (especially the print companies). So while trying to add support for the latest OS features that some people request (or just trying to stay current with the compiler and programming state of the art), you have this huge percentage of clientele who drag you down and cause severe support and dev headaches.


Return to “Vienna”

Who is online

Users browsing this forum: Google [Bot], Yahoo [Bot]