Headlines for some feeds are not displayed with version 2.4

An RSS/Atom newsreader with features comparable to commercial newsreaders.
philippeschmid
Harmless
Posts: 1
Joined: Fri Jan 15, 2010 7:49 am

Headlines for some feeds are not displayed with version 2.4

Postby philippeschmid » Fri Jan 15, 2010 8:01 am

Hi,
Since 2.4, some feeds don't show in the headlines pane. The nb. of new/unread headlines is displayed right to the feed name.
Running Vienna 2.4.0.2401 on MacOS 10.6.2 in french. Removing the feed and re-adding it does not help.

Ex. of non-functionning feeds :
http://www.macnn.com/macnn.rss
http://rss.slashdot.org/Slashdot/slashdot
http://digg.com/rss/index.xml

best regards,
Philippe

User avatar
Michael Ströck
Vienna Team
Posts: 303
Joined: Mon Mar 06, 2006 9:21 am
Location: Vienna, Austria
Contact:

Re: Headlines for some feeds are not displayed with version 2.4

Postby Michael Ströck » Fri Jan 15, 2010 12:28 pm

They all work on my three machines - could you send a screenshot just to make sure we're talking about the same thing?

Pareidolic
Harmless
Posts: 1
Joined: Wed Feb 24, 2010 9:46 pm

Re: Headlines for some feeds are not displayed with version 2.4

Postby Pareidolic » Wed Feb 24, 2010 10:07 pm

I have something here that sounds very similar: Certain feeds appear in the list on the left side, get listed as usual with their number of unread messages, but when i click on them the list of messages in that feed stays empty as if there were no messages at all in it. For other feeds the display works as usual, but apparently no new messages are added when updating the feeds.

I debugged a bit and what I found out was that the root cause in my case is that the sqlite database got corrupted, which may have been caused by a power loss I had yesterday. The problem is basically that the query "select * from messages where (folder_id=11)" returns an error code 11 (SQLITE_CORRUPT) at the call listed below. When i try to access the same data with the sqlite client I get "Error: database disk image is malformed". For other parts of the database, for other folder_ids there is no error, I guess the corrupted area is not used when reading them.

I don't think there is anything that can be fixed about this from the side of Vienna, I guess I simply have to restore the database file (/Users/[user]/Library/Application Support/Vienna/messages.db) from my backups.


Call accessing the corrupted data:
#0 0x00009535 in -[SQLDatabase performQuery:] at SQLDatabase.m:199
#1 0x00018464 in -[Database arrayOfArticles:filterString:] at Database.m:2269
#2 0x0000bc83 in -[Folder articlesWithFilter:] at Folder.m:718
#3 0x00063f0c in -[ArticleController reloadArrayOfArticles] at ArticleController.m:295
#4 0x0006d0e4 in -[ArticleListView selectFolderWithFilter:] at ArticleListView.m:1127
#5 0x00063e4a in -[ArticleController displayFolder:] at ArticleController.m:282

User avatar
Michael Ströck
Vienna Team
Posts: 303
Joined: Mon Mar 06, 2006 9:21 am
Location: Vienna, Austria
Contact:

Re: Headlines for some feeds are not displayed with version 2.4

Postby Michael Ströck » Wed Feb 24, 2010 10:56 pm

Hi Pareidolic,

That does sound like a corrupted database... SQLite files are really hard to kill without hardware failures, so the power failure might have been an issue. The easiest way to do resolve this, unfortunately, is to delete the corrupted database...


Return to “Vienna”

Who is online

Users browsing this forum: No registered users