Page 1 of 1

2.3.4 error when auto checking for updates

Posted: Thu Jan 14, 2010 9:57 pm
by AriaPictures
Turned on vienna 2.3.4 on 10.5.8 and said there was an update of 2401 and clicked "Install Update" and got an error:
Update Error!
An error occurred while trying to download the file. please try again later.


do I go get it through the site and will the next auto update and install work?

Re: 2.3.4 error when auto checking for updates

Posted: Fri Jan 15, 2010 7:57 am
by David Munch
Seeing the same thing. I can't upgrade to 2.4.. :)

Edit: Just noticed - I'm running 2400 (2.4 is 2401).

Re: 2.3.4 error when auto checking for updates

Posted: Fri Jan 15, 2010 10:39 am
by rob.h
Same here, although I got around it by manually downloading and installing version 2.4

Re: 2.3.4 error when auto checking for updates

Posted: Sat Jan 16, 2010 12:11 am
by blubalu
I'm running 2.3.4.2305 right now and get the same error when trying to update to 2.4. Any news on this bug?

Re: 2.3.4 error when auto checking for updates

Posted: Sat Jan 16, 2010 12:39 am
by Michael Ströck
blubalu wrote:I'm running 2.3.4.2305 right now and get the same error when trying to update to 2.4. Any news on this bug?


Unfortunately not - I have no idea what's going on ATM... I hope to find out soon. In the meantime, though, You can just download 2.4 from the website.

Re: 2.3.4 error when auto checking for updates

Posted: Sun Jan 17, 2010 1:16 pm
by Michael Ströck
Jeff Johnson just wrote me this Email:

Ok, after much experimentation, I've finally discovered the real problem: SourceForge. Their servers seem to be randomly cutting off the downloads. It has nothing to do with nibs or ditto or Sparkle or NSURLDownload. Try this several times in a row:

$ curl 'http://master.dl.sourceforge.net/project/vienna-rss/ReleasedVersions/2.4.0/Vienna2.4.0.2401.zip' > Vienna2.4.0.2401.zip
% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed
88 3928k 88 3486k 0 0 497k 0 0:00:07 0:00:07 --:--:-- 558k
curl: (18) transfer closed with 451913 bytes remaining to read


So the problem lies with SourceForge. I'll try to find out what's going on.

Re: 2.3.4 error when auto checking for updates

Posted: Sun Jan 17, 2010 1:27 pm
by blubalu
I was successful in downloading the english-only version in the meantime.
Good luck hunting down the SF bug.

Re: 2.3.4 error when auto checking for updates

Posted: Sun Jan 17, 2010 4:31 pm
by Michael Ströck
blubalu wrote:I was successful in downloading the english-only version in the meantime.
Good luck hunting down the SF bug.


Jeff just made a change that should solve the problem. It's working for me now.