[BUG?] Vienna Version 2.4.0.2401 binary lacks +x flag

An RSS/Atom newsreader with features comparable to commercial newsreaders.
fnark
Harmless
Posts: 1
Joined: Tue Jan 12, 2010 9:45 pm

[BUG?] Vienna Version 2.4.0.2401 binary lacks +x flag

Postby fnark » Tue Jan 12, 2010 9:51 pm

Hey,

I just updated to said version, or rather the auto updater did it.
After downloading the new binary etc., it went for the restart but never came back because apparantly the vienna binary in Contents/MacOS lacked the +x flag. A chmod +x fixed it. I'm not sure it it's just me or a buggy installer. I just wanted to inform you guys.

MacOS X Version is 10.6.2.

User avatar
huski
Harmless
Posts: 4
Joined: Mon Jun 16, 2008 9:56 am
Location: EU
Contact:

Re: [BUG?] Vienna Version 2.4.0.2401 binary lacks +x flag

Postby huski » Tue Jan 12, 2010 10:26 pm

In my case auto update also didn't work. I was getting this msg:
screenshot 2010-01-12 at 22.23.34.png

stevepa
Vienna Team
Posts: 469
Joined: Fri Jan 13, 2006 3:13 pm

Re: [BUG?] Vienna Version 2.4.0.2401 binary lacks +x flag

Postby stevepa » Tue Jan 12, 2010 11:09 pm

Are you running Mac OSX 10.5? Version 2.4 now requires this version or later. I'm not sure what the experience would be if you were running 10.4 or earlier before the update.

I tested the auto-update just now and it worked fine. So assuming you're running the correct version of Mac OSX, I'm not sure what happened there. The attributes are certainly correct after the update. I wonder if that was just (hopefully) a temporary glitch with the SourceForge server?

curiousjp
Harmless
Posts: 2
Joined: Tue Jan 12, 2010 11:43 pm

Re: [BUG?] Vienna Version 2.4.0.2401 binary lacks +x flag

Postby curiousjp » Tue Jan 12, 2010 11:46 pm

Same bug here, OSX 10.6.2 . Adding +x allows it to launch, but now you get trapped in an endless cycle of
feedlight.jpg


Hitting enter just presents the same dialogue again.

psinno
Harmless
Posts: 6
Joined: Fri Sep 05, 2008 7:22 pm

Re: [BUG?] Vienna Version 2.4.0.2401 binary lacks +x flag

Postby psinno » Wed Jan 13, 2010 12:03 am

curiousjp wrote:Same bug here, OSX 10.6.2 . Adding +x allows it to launch, but now you get trapped in an endless cycle of
feedlight.jpg


Hitting enter just presents the same dialogue again.


Exact same for me. I have 10.5.8 so it doesn't seem to be OSX version specific. The english only version from the website works fine.

User avatar
Michael Ströck
Vienna Team
Posts: 303
Joined: Mon Mar 06, 2006 9:21 am
Location: Vienna, Austria
Contact:

Re: [BUG?] Vienna Version 2.4.0.2401 binary lacks +x flag

Postby Michael Ströck » Wed Jan 13, 2010 12:15 am

psinno wrote:
curiousjp wrote:Same bug here, OSX 10.6.2 . Adding +x allows it to launch, but now you get trapped in an endless cycle of
feedlight.jpg


Hitting enter just presents the same dialogue again.


Exact same for me. I have 10.5.8 so it doesn't seem to be OSX version specific. The english only version from the website works fine.


I'm stumped right now - I don't know how this is happening. Could you please go to ~/Library/Application Support/Vienna (in your home folder) and check whether there is a file called "FeedLight Aqua (Default).viennastyle".

Could you also please try downloading the localized version again through by following the link on the website and see if the error persists?

eloqui
Harmless
Posts: 1
Joined: Wed Jan 13, 2010 12:09 am

Re: [BUG?] Vienna Version 2.4.0.2401 binary lacks +x flag

Postby eloqui » Wed Jan 13, 2010 12:18 am

After using the auto-updater on a 10.5.8 system, on launch I got an error message that the app could not run on my architecture (sorry I don't have a screen capture, nor can I now replicate the problem). Replacing the app with a copy downloaded from the website however works fine.

User avatar
Michael Ströck
Vienna Team
Posts: 303
Joined: Mon Mar 06, 2006 9:21 am
Location: Vienna, Austria
Contact:

Re: [BUG?] Vienna Version 2.4.0.2401 binary lacks +x flag

Postby Michael Ströck » Wed Jan 13, 2010 12:36 am

eloqui wrote:After using the auto-updater on a 10.5.8 system, on launch I got an error message that the app could not run on my architecture (sorry I don't have a screen capture, nor can I now replicate the problem). Replacing the app with a copy downloaded from the website however works fine.


Thanks for the feedback, glad it's now working for you. I can also not replicate any of the issues at the moment. The update also worked on Steve's machine. I'm mystified, TBH.

psinno
Harmless
Posts: 6
Joined: Fri Sep 05, 2008 7:22 pm

Re: [BUG?] Vienna Version 2.4.0.2401 binary lacks +x flag

Postby psinno » Wed Jan 13, 2010 12:43 am

Michael Ströck wrote:I'm stumped right now - I don't know how this is happening. Could you please go to ~/Library/Application Support/Vienna (in your home folder) and check whether there is a file called "FeedLight Aqua (Default).viennastyle".


As I said I have downloaded from the website and that version works so this info may be tainted by that.

skilluck:Vienna petersinnott$ ls -l ~/Library/Application\ Support/Vienna/
total 135488
drwxr-xr-x 16 petersinnott staff 544 26 Jun 2009 Images
drwxr-xr-x 23 petersinnott staff 782 13 Jan 00:30 Sources
-rw-r--r-- 1 petersinnott staff 35405824 13 Jan 00:30 messages.db
-rw-r--r-- 1 petersinnott staff 33963008 12 Jan 23:23 messages.db.bak


skilluck:~ petersinnott$ find /Applications/Vienna.app/|grep style$|grep FeedLight
/Applications/Vienna.app//Contents/SharedSupport/Styles/FeedLight Aqua (Default).viennastyle
/Applications/Vienna.app//Contents/SharedSupport/Styles/FeedLight Graphite.viennastyle

User avatar
Michael Ströck
Vienna Team
Posts: 303
Joined: Mon Mar 06, 2006 9:21 am
Location: Vienna, Austria
Contact:

Re: [BUG?] Vienna Version 2.4.0.2401 binary lacks +x flag

Postby Michael Ströck » Wed Jan 13, 2010 12:47 am

curiousjp wrote:Same bug here, OSX 10.6.2 . Adding +x allows it to launch, but now you get trapped in an endless cycle of
feedlight.jpg


Hitting enter just presents the same dialogue again.


Please try this:

1) Quit Vienna
2) Download this file: http://www.vienna-rss.org/userstyles/Fe ... astyle.zip
3) Extract the .zip archive
4) Double-click the resulting .viennastyle file
5) Vienna should start and install the style if it is indeed missing, breaking the circle.

User avatar
Michael Ströck
Vienna Team
Posts: 303
Joined: Mon Mar 06, 2006 9:21 am
Location: Vienna, Austria
Contact:

Re: [BUG?] Vienna Version 2.4.0.2401 binary lacks +x flag

Postby Michael Ströck » Wed Jan 13, 2010 1:17 am

OK - there was definitely something wrong with the zip-archive that we were using for distribution. Two out of the three zip-capable apps on my machine failed to unzip the file correctly. I have uploaded a new archive which unzips without any problems.

How that might have caused the problems, I have no idea. It's definitely better than before, though :-)

Remarksman
Harmless
Posts: 1
Joined: Wed Jan 13, 2010 1:14 am

Re: [BUG?] Vienna Version 2.4.0.2401 binary lacks +x flag

Postby Remarksman » Wed Jan 13, 2010 1:44 am

I don't even get the alert dialog after auto-updating on 10.6.2.
Instead, nothing apparently happens, but I do get this message on the console:

Code: Select all

1/12/10 5:08:25 PM   com.apple.launchd.peruser.502[100]   ([0x0-0x4d04d].uk.co.opencommunity.vienna2[661]) posix_spawn("/Applications/Vienna.app/Contents/MacOS/Vienna", ...): Permission denied
1/12/10 5:08:25 PM   com.apple.launchd.peruser.502[100]   ([0x0-0x4d04d].uk.co.opencommunity.vienna2[661]) Exited with exit code: 1

chmod a+x of Vienna.app/Contents/MacOS/Vienna did not fix anything.
I'll post again if downloading a fresh copy doesn't fix it.

User avatar
Michael Ströck
Vienna Team
Posts: 303
Joined: Mon Mar 06, 2006 9:21 am
Location: Vienna, Austria
Contact:

Re: [BUG?] Vienna Version 2.4.0.2401 binary lacks +x flag

Postby Michael Ströck » Wed Jan 13, 2010 2:01 am

Remarksman wrote:I don't even get the alert dialog after auto-updating on 10.6.2.
Instead, nothing apparently happens, but I do get this message on the console:

Code: Select all

1/12/10 5:08:25 PM   com.apple.launchd.peruser.502[100]   ([0x0-0x4d04d].uk.co.opencommunity.vienna2[661]) posix_spawn("/Applications/Vienna.app/Contents/MacOS/Vienna", ...): Permission denied
1/12/10 5:08:25 PM   com.apple.launchd.peruser.502[100]   ([0x0-0x4d04d].uk.co.opencommunity.vienna2[661]) Exited with exit code: 1

chmod a+x of Vienna.app/Contents/MacOS/Vienna did not fix anything.
I'll post again if downloading a fresh copy doesn't fix it.


OK, another error that I don't understand, nor can I replicate it... Thanks for all your feedback, auto-update is disabled for now. We'll look into these issues.

curiousjp
Harmless
Posts: 2
Joined: Tue Jan 12, 2010 11:43 pm

Re: [BUG?] Vienna Version 2.4.0.2401 binary lacks +x flag

Postby curiousjp » Wed Jan 13, 2010 3:22 am

Michael Ströck wrote:I'm stumped right now - I don't know how this is happening. Could you please go to ~/Library/Application Support/Vienna (in your home folder) and check whether there is a file called "FeedLight Aqua (Default).viennastyle".


No such file. Just the sources folder, images folder and messages.db.

Michael Ströck wrote:1) Quit Vienna
2) Download this file: http://www.vienna-rss.org/userstyles/Fe ... astyle.zip
3) Extract the .zip archive
4) Double-click the resulting .viennastyle file
5) Vienna should start and install the style if it is indeed missing, breaking the circle.


This didn't work either. Is it possible Vienna is trying to initialise its style code before getting to the part where it would install the new item?

Michael Ströck wrote:Could you also please try downloading the localized version again through by following the link on the website and see if the error persists?


This fixes the problem. Thanks! Hope you get to the bottom of what it was soon. :)

B.

stevepa
Vienna Team
Posts: 469
Joined: Fri Jan 13, 2006 3:13 pm

Re: [BUG?] Vienna Version 2.4.0.2401 binary lacks +x flag

Postby stevepa » Thu Jan 14, 2010 8:15 pm

Thanks to everybody who reported this issue and apologies to all who were inconvenienced. The problem seems to be resolved now with a new upload to SourceForge. We're not entirely sure what the root cause of the original issue was but I'm still comparing the broken versus working zip file.

-Steve


Return to “Vienna”

Who is online

Users browsing this forum: No registered users