Adium conflicts with Google video chat plugin

An instant messenger which can connect to AIM, GTalk, Jabber, ICQ, and more.
coppelius
Harmless
Posts: 1
Joined: Mon Sep 21, 2009 6:33 pm

Adium conflicts with Google video chat plugin

Postby coppelius » Mon Sep 21, 2009 6:56 pm

For a long time, my "Insert link to active page in [browser]" button has been broken, for all browsers (and presumably all protocols, but I only use AIM and Google Talk). When I press the button for the first time, Adium thinks for a bit, and eventually an error chime is played, but nothing else happens. On successive presses, the error chime sounds immediately, but still nothing else happens. However, typing "%_safari" has always worked fine, so I never bothered to try and fix the issue. I finally got fed up with having to type in %_safari, so I did some investigating. I discovered the following message in the console:

Code: Select all

9/21/09 12:57:21 PM [0x0-0x44e44e].AdiumApplescriptRunner[9984] [000:002] MagicCam 0: Current process: AdiumApplescriptRunner, Flash is loaded: no
9/21/09 12:57:21 PM [0x0-0x44e44e].AdiumApplescriptRunner[9984] [000:002] Error(magiccammac.cc:276): MagicCam 0: MagicCamOpen: Not an allowed process!


Googling for magiccammac.cc, I discovered numerous people who had encountered the same problem. The suggested solution was to remove the Google Camera Adapter components from /Library/QuickTime/ . However, mine were located in /Library/Components/ instead. Removing the two files (Google Camera Adapter 0.component and Google Camera Adapter 1.component) solved the problem. I wasn't able to find anyone else with the same problem on these forums.

This isn't so much a bug report, because it very well might be Google's bug, since there seem to be plenty of similar reports of conflicts with other programs. However, I'm curious to see if other Adium users who have the Google video plugin installed have encountered similar problems. I also think there might be a possible workaround that Adium could do in the background, since typing %_safari has always worked for me.

OS X 10.5.8 Intel
Adium 1.3.6

Return to “Adium”

Who is online

Users browsing this forum: No registered users