Search found 6 matches

by AstralBoy
Wed Feb 15, 2012 6:57 pm
Forum: Perian
Topic: MPEG-2 Video/Audio out of sync in Compressor
Replies: 10
Views: 14822

Re: MPEG-2 Video/Audio out of sync in Compressor

Oh sorry. I forgot to mention that Apple's H.264 decoder does not support the profile level used by lossless H.264. With Perian disabled, regular H.264 decodes fine, but only the lossless video doesn't decode. It's frustrating because Perian works fine for this for so many others.
by AstralBoy
Wed Feb 15, 2012 6:24 pm
Forum: Perian
Topic: MPEG-2 Video/Audio out of sync in Compressor
Replies: 10
Views: 14822

Re: MPEG-2 Video/Audio out of sync in Compressor

When I remove Perian then the video won't decode at all.

x264, the open source H.264 encoder that HandBrake uses, has a lossless mode when RF 0 is selected.

Where is the DecodeAllProfiles preference? I can't seem to find it.
by AstralBoy
Tue Feb 14, 2012 10:10 pm
Forum: Perian
Topic: MPEG-2 Video/Audio out of sync in Compressor
Replies: 10
Views: 14822

Re: MPEG-2 Video/Audio out of sync in Compressor

I can run the video through HandBrake losslessly crop it, detelecine it, and resize it, so that I can run the video stream by itself through Compressor. But there I run into another problem... Perian doesn't seem to fully support lossless H.264. http://i.imgur.com/lGlwQ.png All through the video the...
by AstralBoy
Tue Feb 14, 2012 2:15 am
Forum: Perian
Topic: MPEG-2 Video/Audio out of sync in Compressor
Replies: 10
Views: 14822

Re: MPEG-2 Video/Audio out of sync in Compressor

It can, but it won't decode the audio if I disable Perian. I think it's an issue with Compressor, rather than Perian. There doesn't seem to be a difference in its behavior when decoding MPEG-2 video with Perian disabled though, which leads me to believe that it relies on its own decoder rather than ...
by AstralBoy
Mon Feb 13, 2012 9:36 pm
Forum: Perian
Topic: MPEG-2 Video/Audio out of sync in Compressor
Replies: 10
Views: 14822

Re: MPEG-2 Video/Audio out of sync in Compressor

Yes, 29.97 fps. I'm detelecining it in my conversion.
by AstralBoy
Mon Feb 13, 2012 4:23 am
Forum: Perian
Topic: MPEG-2 Video/Audio out of sync in Compressor
Replies: 10
Views: 14822

MPEG-2 Video/Audio out of sync in Compressor

I haven't encountered the problem in any other application. I'm not sure if it's the video being played back at inconsistent speeds, or the audio being decoded incorrectly, but the two very quickly go out of sync. What's interesting to note is that the video looks like it's being played back too qui...

Go to advanced search